3D Printing, Illusive Fixes, and Other Crap

No Space Left On Device vmware_locker_tools error when upgrading ESXI 6.7

So, got this error recently when attempting to upgrade from ESXI 6.7u1 to 6.7u2:

[InstallationError]
[Errno 28] No space left on device
vibs = VMware_locker_tools-light_10.3.5.10430147-12986307
Please refer to the log file for more details.

Yuck. [Note, the version of locker tools you’re missing will likely vary from mine, but you can use this article and just swap out the version vmware is whining about].

The solution is simple. The “no space left” is kind of a default “stopper” that shows up — you’re not actually out of space. However, there’s a VIB file that is a prerequisite prior to upgrading to whatever version of ESXI you’re trying to get to.

In this case, that item is VMware Locker Tools Light.

Run the following 3 lines individually to get it installed:

cd /tmp

wget http://hostupdate.vmware.com/software/VUM/PRODUCTION/main
/esx/vmw/vib20/tools-light/VMware_locker_tools-light_10.3.5.10430147-12986307.vib

esxcli software vib install -f -v /tmp/VMware_locker_tools-light_
10.3.5.10430147-12986307.vib

Now you can run your upgrade. I typically use this website as a nice resource for my upgrades to my ESXI hosts.

Next Post

Previous Post

1 Comment

  1. xavier May 24, 2019

    many thanks for this tip

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.

© 2019 Ganon.Club

Theme by Anders Norén